Publicadas nuevas actualizaciones de las aplicaciones Logic Pro X y GarageBand, que solucionan importantes vulnerabilidades.

Recursos afectados

Apple Logic Pro X 10.1 y 10.2
Apple GarageBand 10.1

Solución

Actualizar las aplicaciones a las versiones no vulnerables, Logic Pro X 10.3 y GarageBand 10.1.5.

Desde la OSI siempre aconsejamos que las aplicaciones que tengan la posibilidad de actualizaciones automáticas, se activen, ya que se evitan gran parte de los problemas de seguridad.

Detalles

Apple ha actualizado las aplicaciones Logic Pro X y GarageBand, solucionado entre otros, un problema de seguridad (CVE-2017-2372) que podría permitir que un atacante ejecutase código  de forma remota en un equipo con una versión vulnerable de alguna de estas aplicaciones.

Aunque ambos programas tienen como opción la actualización automática, en muchos casos no se tiene activada, ya que su instalación pueden producir malfuncionamiento en los periféricos (tarjetas de sonido, controladores MIDI, etc.) conectados debido a problemas con los controladores.